2004 Nissan Armada 5.6 L cranks but won’t start

Posted by mellassi on January 18, 2014 under Imports | Be the First to Comment

We can’t get no communication with the scan tool, engine has no spark and no injector pulse.

1. With the key on check for power to the ignition coils on the White/Blue wire. If there is no power, check the operation of the engine control module main relay which is located in the engine room Intelligent Power Distribution Module (IPDM). This relay also powers up the engine control module.

2. If the coils have power, check for loss of signal from either the camshaft or crankshaft position sensor. Both should output square wave signals during cranking.

I switched the fog light relay with the main relay, engine starts. got new relay,  problem fixed.

2003 Nissan Murano SE 3.5 no start no fuel pressure

Posted by mellassi on January 15, 2014 under Imports | Be the First to Comment

with the ignition key in the on position,  the fuel pump should run for a couple of seconds. if you don’t hear it running, check the fuel pump harness for battery voltage and ground, you can access the fuel pump by removing the rear seat  cushion out. the black/yellow wire (harness side color) , should have 12v with the key on for a couple of seconds or while cranking. the ground is on the black wire. if power and ground are present , the fuel pump is faulty.

If there is no voltage to the fuel pump, check 15 amp fuel pump fuse 81 in Intelligent Power Distribution Module (IPDM) for being loose, blown, or missing.