valve cover gasket replacement on a Toyota Camry 2.2 L

Posted by mellassi on January 27, 2015 under Imports | Be the First to Comment

How to Replace a Valve Cover Gasket – Toyota Camry 2.2L Engine


How to reset oil light on 2007 Honda Odessy

Posted by mellassi on November 29, 2014 under Imports | Be the First to Comment

To reset oil light do the following:

1. Turn the ignition to run (one position before starting engine).
2. Press the SELECT/RESET knob repeatedly until the engine oil life indicator is displayed.
3. Press the SELECT/RESET knob for more than 10 seconds. The engine oil life indicator and the maintenance code(s) will blink.
4. Press the SELECT/RESET knob for more than 5 seconds. The maintenance items code(s) will disappear, and the engine oil life will reset to 100.
5. Turn the ignition off and then start the engine to verify the indicator has been reset.

Watch this Youtube video for more info:




 

 

2000 Honda CR-V EX 2.0 L The Idle Surge up and down

Posted by mellassi on November 24, 2014 under Imports | Be the First to Comment

why Idle problems :

1. When idle surge occurs, remove the air boot from the throttle body, block the throttle body and verify that the engine will stall.

2. Verify that the power steering switch reads correctly on the scan tool. The power steering switch should change when the wheels are turned all the way. The switch should read open with high power steering pressure.

3. Next, block the air port for the Idle Air Control (IAC) valve in the throttle body and see if the idle slows down and the surging stops. If the idle slows down, verify that there is hot coolant to the IAC valve.

4. Next, verify that the duty control on the Black/Blue (BLK/BLU) wire for the IAC valve is the same or less when the engine idles normally or when it idles high and surges. If the duty control is OK, then check for a sticking or faulty IAC valve.

The idle Air Control valve is located in back of the intake.

iac honda    iac Honda

1997 Nissan Maxima GXE 3.0L misfire code p1320

Posted by mellassi on February 28, 2014 under Imports | Be the First to Comment

The common cause of code p1320 (ignition control signal circuit malfunction) is the ignition coils.

If code p1320 is accompanied with codes p0301, p0302, p0303,p0304,p0305, 0r p0306, its defiantly the ignition coil for that specific cylinder.

Its recommended to replace the ignition coils with Original equipment ,  aftermarket coils may turn on code p1320.

also its recommended to use NGK spark plus on a Nissan engines.

 

2008 Volkswagen passat 2.0T Engine makes a whistle noise

Posted by mellassi on January 21, 2014 under Imports | Be the First to Comment

Usually the whistle noise is due to large amount of a vacuum leak in the crankcase.

-There are 2 crankcase breather valves (PCV system) used on this engine. One is located on the valve cover of the engine and the other is located within the oil filter housing (intake manifold must be removed to replace oil filter housing). These valves control crankcase ventilation.

-If either the valve cover breather valve diaphragm or the oil filter housing breather valve fails, manifold vacuum can be introduced to the crankcase causing idle quality issues as well as various lean condition codes.

-Remove the dipstick and check for excessive crankcase vacuum (more than 1″ Hg). If excessive crankcase vacuum is present, block off the vacuum tube to the valve cover breather valve to eliminate the vacuum source. If crankcase vacuum is now normal, the valve cover breather valve is faulty and the breather must be replaced.

– If there is no change from blocking the valve cover vacuum source, locate the vacuum tube to the oil filter housing. Disconnect the tube at the housing and block off the vacuum from the intake manifold. If the crankcase vacuum is now normal, the oil filter housing must be replaced.

-In some cases a loud whining or moaning noise from the rear of the engine can be heard (has been described as a noise from the transmission as well). This is caused by the vacuum in the crankcase pulling air past the rear main seal. When the noise occurs, remove the oil fill cap and if the noise disappears, then either of the crankcase breather valves may be faulty and should be tested as described above.

a common problem with these car is the valve cover breather valve.

download (5)

2001 Volvo S40 1.9L does not start

Posted by mellassi on January 20, 2014 under Imports | Be the First to Comment

Engine will not crank over

1-check for any flushing lights in the instrument cluster, if yes, anti theft problem, you may try another key.

2-. Check fuse 11A/13 (for model year 2000 vehicles) or 11A/11 (for 2001 and newer models). If this is blown, check the wiring underneath the spark plug/ignition coil cover.

3-2. At the starter relay, check for power on terminal 3 at all times. Check for power on terminal 1 with the key in the crank position. If there is no power from the ignition switch, remove and attempt to turn with a small screwdriver. If it will crank, replace the steering wheel lock (tumbler assembly). If there is no power out of the ignition switch on terminal 4 (Green wire) with the switch in the crank position, replace the ignition switch.

4-Jump terminals 3 and 5. The engine should crank.

5- If the engine cranks, check for ground on terminal 2. Ground is supplied through the Gear Position Sensor (GPS) and the immobilizer.

6-If there is never a ground from the immobilizer control module, ensure key being used is programmed to the vehicle.try  another key; check trouble codes in the immobilizer.

 

2004 Nissan Armada 5.6 L cranks but won’t start

Posted by mellassi on January 18, 2014 under Imports | Be the First to Comment

We can’t get no communication with the scan tool, engine has no spark and no injector pulse.

1. With the key on check for power to the ignition coils on the White/Blue wire. If there is no power, check the operation of the engine control module main relay which is located in the engine room Intelligent Power Distribution Module (IPDM). This relay also powers up the engine control module.

2. If the coils have power, check for loss of signal from either the camshaft or crankshaft position sensor. Both should output square wave signals during cranking.

I switched the fog light relay with the main relay, engine starts. got new relay,  problem fixed.

2003 Nissan Murano SE 3.5 no start no fuel pressure

Posted by mellassi on January 15, 2014 under Imports | Be the First to Comment

with the ignition key in the on position,  the fuel pump should run for a couple of seconds. if you don’t hear it running, check the fuel pump harness for battery voltage and ground, you can access the fuel pump by removing the rear seat  cushion out. the black/yellow wire (harness side color) , should have 12v with the key on for a couple of seconds or while cranking. the ground is on the black wire. if power and ground are present , the fuel pump is faulty.

If there is no voltage to the fuel pump, check 15 amp fuel pump fuse 81 in Intelligent Power Distribution Module (IPDM) for being loose, blown, or missing.

 

 

 

1996 Honda accord lx start for 3-5 seconds and stall

Posted by mellassi on under Imports | Be the First to Comment

most common problems with Honda  is the PGM-FI (programmed Fuel Injection) main relay.

1. make sure the dash light work . if not, check  battery voltage to the Black/Yellow wire off the ignition switch,if there is no power, change ignition switch.

2.check fuel pressure,if there is no pressure, then verify there is good battery voltage from the PGM-FI main relay to the fuel pump and if there is low voltage suspect the PGM-FI main relay.

the PGM-FI cost about 35.00 at most auto parts stores , and it is easy to replace. it is located under the driver side dash board ,by the steering column.

pgm-fi honda accordpgm-fi main relay

 

2004 Chevrolet Impala 3.4L, V6 hesitates

Posted by mellassi on under Imports | Be the First to Comment

customer complain:

Car bogs out when accelerating, idles fine, has misfire codes p0300.

diagnostics:

1-tested fuel pressure, added carburetor cleaner during acceleration, still bogs out.

2-disconnect MAF sensor,retest, runs better.

Possible causes:

.Faulty MAF sensor.

.vacuum leak after MAF sensor.

.MAF sensor power and ground.

fix:

replace new MAF sensor.